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Opening a Font

File -> Open
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The Font Table
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The Font Table

Cells
Labels

Colors
Yellow � encoded
Gray � unencoded
Red � marked
Green � selected

Types
Background colors

White w/ black glyph = character+glyph
White w/o glyph = character, no glyph
Gray w/ gray glyph = no char or glyph
Gray w/ no glyph = no char,glyph,template
Dark blue = selected
Red, green cyan,�= marked
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The Font Table

Cell icons
H (LLQ) � character has hint replacement program or
overlapping T1 hints

Green = good
Red = bad

T (RLQ) � has TT hints
Blue = original
Brown = manual

M (RUQ) � has mask layer
Ylw/grn = compatible
Ylw/rd = incompatible

Note � has note. RMB/<ctrl> click-hold to read it
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The Font Table

Encoding modes
Name
Unicode Ranges
Unicode Codepages
Index

Save encoding � saves .enc file
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The Font Table

Selecting � click cell
Drag-and-drop
Range drag-and-drop

New glyph �dbl click
+<ctrl> - multiple windows
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The Font Table

RMB/<ctrl>-click menu
Width � of table
Copy/Paste � all layers
Append � to end of table
Delete
Action
Add note
Rename
Mark � marks and unmarks cells
Open � open in new window
Properties � glyph properties
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The Font Table

RMB/<ctrl>-click menu
Width
More

Select encoding
Select glyph as default
Remove Unicode
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The font Table

Customizing the font table:
Size
Caption
Mode
Encoding
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The Glyph Edit Window
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Glyph Edit Window

Edit tool
Click = select
Click-drag = move
Dbl-click = select
contour

Erase tool

Knife tool

Meter

Drawing Pen
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Glyph Edit Window

VectorPaint Tools
Lasso
Pencil
Brush
Line
Polygon
Text tool
Color

Empty
Auto
Black
White

Brush Options
Brush Style
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Glyph Edit Window

Guidelines
Horizontal
Vertical
Diagonal
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Metrics
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Metrics and kerning window

Window->new metrics
window

Mode
Text
Preview
Metrics
Kerning
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Metrics and kerning Window

Text size

Options

Tools

Text string
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Metrics and kerning window

Metrics Mode

Sidebearings

Auto
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Metrics and kerning window

Kerning Mode

Manual vs
digital

Auto
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Font Info
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Font Info

Names and copyright

Version and ID

Metrics and dimensions

Encoding and Unicode

Hinting settings

Type 1 settings

TrueType settings
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Font Info

Names
Font name
Family name
Menu name

Copyright
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Font Info

Version

Metrics

Encoding
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Font Info

Font Note
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Font Generation
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Font generation

Saving - .vfb format
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Font Generation

Windows
Type 1
TrueType/OpenType

Macintosh
Type 1
TrueType/OpenType
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   1

PostScript Type 1
created 1985�1990 by Adobe Systems
declared obsolete in 1999   

exists in two platform variants:

  *
resource-fork suitcase + �LWFN� printer file(s)
works on   and   
doesn�t work on Windows

  

2 4 data-fork files (.pfb, .pfm + possibly .afm, .inf)
works on  and some Unix/Linux systems
doesn�t work on MacOS 8/9 or Mac OS X

* only supported in FontLab for Mac
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  

OpenType / TrueType
created 1987 by Apple and Microsoft
extended 1996�1999 by Microsoft and Adobe
exists in two flavors:

    

one data-fork file per style, extension .ttf
works on  and   , Unix
doesn�t work on MacOS 8/9

  (PostScript/CFF)
one data-fork file per style, extension .otf
works on       Unix
doesn�t work on MacOS 8
support limitations on other systems
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the
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OpenType � What is it?
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OpenType � What is it?

TrueType with more tables.

Uses one file (the same file) for both Mac and PC

Allows very sophisticated typography through the use of OpenType
features (in applications that support OpenType)

Can use either TT or T1 glyphs.
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Readings on OpenType

OpenType: The Next Level of Digital Typography (Mark
Eastman, Communication Arts)

http://store.adobe.com/type/opentype/CA-Aug02.pdf

OpenType ushers in new era of typography (Edward
Mendelson, Creativepro.com)

http://www.creativepro.com/story/feature/6503.html

Will Adobe Finally Push OpenType into the Big Time? (Terri
Stone, Macworld)
http://www.macworld.com/2001/08/bc/20adobe_opentype/
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OpenType References

Specifications

Microsoft:
http://www.microsoft.com/typography/tt/tt.htm

Adobe:
http://partners.adobe.com/asn/tech/type/opentype/otover.jsp

47 

6

The Hard Way
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OpenType the Hard Way

Design Glyphs

Do metrics and kerning

Hint glyphs

Name and encode glyphs

Write OT feature scripts

Test and debug OT feature scripts

Name, ID, and generate the font

Test fonts in OT-compatible apps

Debug and retest, etc.
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The Easy Way
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OpenType the Easy Way

Design Glyphs

Do metrics and kerning

Hint glyphs

Copy/paste characters into FreeFontPro template (or make
your own)

Name, ID, and generate the font - Voila! You�re done.
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opentype the Easy Way

Design Glyphs

Do metrics and kerning

Hint glyphs
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opentype the Easy Way

Copy/paste (special) glyphs into FreeFontPro template (or
make your own)
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opentype - Easy Way
Name, ID, and Generate the
font

FFPro already has built in:
Alt forms
Small caps
Lining figures
Tab figures
Old style numerals
Superiors
Inferiors
Ligatures
Diphthongs
Currencies
Ordinals
Cap spacing
Fractions
as standard OT features
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OpenType the Easy Way

Advantages:

Avoid tedious re-entry of Font Info data

Use a template of known quality to eliminate encoding
errors

Eliminate debugging and testing by re-using OT feature
scripts that have already been debugged and tested
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The Really Easy Way
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OpenType the Really Easy Way

Check the �Add OTF features� checkbox

Import a Type 1 font

Name, ID, and Generate the font
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OpenType the Really Easy Way

Check the �Add OTF features� checkbox
Tools->Options->T1 Import
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OpenType the Really Easy Way

Import a Type 1
font

FL automatically
creates:

cpsp
frac
ordn
liga
If the
appropriate
glyphs are
available
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Other OT Shortcuts
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Other OpenType shortcuts

Use Python Macros to create characters

Tim Ahrens� Auto SmallCap
http://www.fontlab.com/html/python.html

Write your own!
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Drawing Power
in
FontLab Studio 5
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The Glyph Window

Scale,zoom

Control marks

Note icon

Rulers and scroll bars

Window options

Glyphs bar

Undo/redo
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Glyph Window controlbar

Scale

Zoom

Meter panel

Control marks (T, R, M)

Note icon
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Glyphs bar & window options
Lock/unlock

Toggle meter panel

Zoom

Expand/close

Selecting a glyph for editing

65 

5

User interface
Meter tool

Meter panel
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User interface - Glyph toolbox
Edit tool

Eraser

Knife

Meter

Pen

Add corner, curve,
tangent

Rectangle, ellipse

Transform

TT and T1 hinting
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User interface - Contour toolbox

Flip: Horizontal and vertical

Interpolate nodes

Envelope

Move node

Simplify segment

Set contour direction (PS,TT)

Merge contours: Get
intersection
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User interface - Editing layers

Editing layer groups window
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User interface - Editing layers

View -> Show
layers

Dockable toolbar
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User Interface

Lock Layers
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User Interface

Snap to Layers
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User interface - Rulers and Guidelines

Scrollbars

Rulers
Units per eM (UPM)

Guidelines
Horizontal & vertical
Angled

3 degree constraint
<shift>

Parallel
Remove
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User interface - Guidelines

Guidelines menu
RMB/<ctrl>click

Convert to global
Align
Delete
Create orthogonal
Properties

Coordinate
Angle
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User Interface Exercise

Open FontLab; Open a font; Open the glyph window;
Select the space character.

Make the grid and guidelines layers visible. Remove all
other layers. Lock the outline layer.

Place a horizontal guide at a level of 402 eM units. Turn it
into a global guide.

Place a 42 degree angle guide at �28. Create another
parallel to it at �20.

Remove all guidelines.
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Edit mode � the edit tool

Node select <shift>

Segment select <shift>

Contour select <x2>

Node properties <ctrl>

Node menu
<RMB>/<cntrl>click

Node insertion <cmd+opt>

Convert to curve <alt>
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Edit mode

The Nodes properties panel <ctrl><click>
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Edit modeEdit mode

The Node menu (RMB/<ctrl>click)

The Node menuThe Node menu
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Edit mode

Eraser
Standard
Marquee <cmd>

Knife
Add node
Cut stem
Delete line <opt>
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Edit Exercise

Open the A glyph cell

Select an apex node and delete it.

Cut one of the legs; select the lower contour; drag it 10
units to the right.

Add a node in the middle of the top of the crossbar; select
the segment to the right; delete it to leave an open
contour.

Select the bottom right node and move it 11 units to the
right and two units up.
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Edit mode

Bezier drawing tool (pen)
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Edit mode

New contour tools
Add corner
Add curve
Add tangent

82 

22

Edit mode

Transform tools
Rotate
Scale
Slant

Transform Box
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Edit Exercise 2

Open a blank glyph window.

Draw a D using the contour tools.

Select the inner contour and scale it up by 10%.

Draw a dot in the counter of the D using the Bezier Pen.

Select the D but not the dot and slant it 12 degrees to the
left (hint: use a guideline).
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Contours

Open and closed

Filled and unfilled

Startpoint and closepath
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Contours

Type 1 (cubic b-spline)

TrueType (quadratic b-
splines)
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Contours

Connections: sharp vs. smooth

Changing connection type
Double-click
RMB/<ctrl>click ->menu
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Contours � node commands

Make node first

Convert

Delete

Duplicate

Retract BCPs

Add anchor
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Contours � contour commands

Reverse

Contour
Make contour first
Delete
Subtract
Select
Make parallel path

Break contour

Make corner

Fixed BCP direction
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Contour Exercise

Open the 5 glyph

Change the extremum node of the bowl to a sharp
connection and make it the first node.

Break the contour at the node in the upper right corner.
Select the top segment and make a parallel path.
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Nodes

Moving nodes and segments

Selection

Click
Marquee
Magic wand

Click-drag

Copy-paste
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Nodes

Inserting nodes

Edit tool
Win: Hold RMB then click LMB
Mac: <cmd><opt>click

Knife tool � click-drag across outline

Add corner, curve, tangent
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Nodes

Removing nodes

Edit tool
Win: Hold LMB then click RMB
Mac: click-drag node then
<ctrl>click

Eraser
Click
Marquee select

Node menu

Edit menu
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Nodes

Non-node editing

94 

34

Selection
Edit tool

<shift>click selects node
Double-click selects contour
Marquee selects segment

Magic wand - <ctrl>+Edit tool
Selects nearest contour
+<alt>/<optn> selects nearest contour & all contours inside it

Lasso � in VP toolbar

Segment
<Shift>click both ends
Marquee select all nodes in segment

Edit menu
Select All
Invert
Deselect
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Glyph popup menu

RMB/<ctrl>click in blank
area

Outline
commands
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Glyph popup menu

Hinting commands

Template
commands
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Glyph popup menu

Actions - transformation

Add note

Add anchor

Add component

Decompose

Open font window
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Glyph properties window

Edit->Properties from Font table

Name & Unicode

# nodes, #contours, #components

Metrics
Standard
Measured at red line

Bounding box

Classes
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Contour Toolbox
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Contour toolbox

Also available from the menu

Flip glyph
Horizontal
Vertical
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Contour toolbox

Interpolate Nodes
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Contour Toolbox
Envelope

Move Node (Set)

Simplify Segment (Curve)
Click tool button
Click each end of segment
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Contour Toolbox
Contour direction

Set PS direction

Set TT direction

Also available from menu

104 



44

Contour Toolbox

Merge Contours

Get Intersection

Delete Intersection (in
menu)
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Masks &
Templates in
FontLab Studio 5

Ted Harrison
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Masks & Templates � what are they?

Mask � a layer of a glyph that can contain a contour that is not
affected by editing the outline layer

Template � a global mask layer

Bitmap layer � a layer in which a bitmap pattern can be imported
or created
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Masks & Templates � where are they?

Tools -> Mask/ & Template
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Masks
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Masks

Copy to Mask � copies the selected contour (or part) to the
mask layer.
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Masks

Paste Mask � copies the mask layer into the outline layer.
Note that it does not replace what was in the outline layer,
nor is the mask removed.
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Masks

Clear Mask � removes all contours from the mask layer
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Masks

Exchange with Mask � moves the outline layer to the
mask layer and the mask layer to the outline layer. All
contours are replaced.
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Masks

Assign Font Mask � makes one font a mask for another
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Masks

Editing the Mask Layer

View->Show Layers->Edit mask
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Exercise 1

Open the H glyph. Select the left half and put it on the
mask layer.

Exchange the mask and outline layers.

Paste the mask layer into the outline layer.

Clear the mask layer.
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Templates
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Templates

Copy to Template � copies the contour (or selected part) from
the outline layer to the template layer.
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Templates

Copy Mask to Template � copies the active glyph�s mask
layer contents into the template layer.
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Templates

Paste Template to Mask � copies the contents of the template
layer into the active glyph�s mask layer.
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Templates

Clear Template � removes the contents of the template layer.
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Exercise 2

Open the T glyph. Copy it to the template layer.

Open the a glyph and copy it to the mask layer. Copy its
mask layer to the template layer.

Open the space character and copy the template to the
mask layer. Then copy the mask layer to the outline layer.

Clear the template layer.
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The Background Layer
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Background

Tools -> Background

Create � rasterizes the outline and puts
the resulting bitmap into the bitmap layer.
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Background

Remove � clears the bitmap layer
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Background

Copy � copies the bitmap to the clipboard

Edit->Paste � copies a bitmap from the clipboard to the
background layer
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Background

Move and Scale � allows you to move and adjust the size and
shape of the bitmap.
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Exercise 3

Open the Z glyph and create a bitmap background from it.

Scale down the bitmap by about half and move it over to
one side.

Clear the background.
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FontLab Studio 5
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VectorPaint � Painting in a vector mode

Bitmap paint tools

Vector contours

Stroke-based contours
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Tools - Lasso

Lasso select � selects enclosed contour
LMB � straight line
RMB � close contour
Edit Tool � move selection
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Tools - Pencil

Freehand line drawing
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Tools - Brush

Brush tips

Brush options

Strokes
Widths
Angle
Caps
Joins
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Tools - Brush

Brush Options

134 
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Exercise 1

Open a new glyph
window and draw a
swash R that looks
something like this. The
stem width should be
60 units.

Draw a grave accent.
Lasso it and drag it over
the R.
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Tools - Line

Straight lines
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Tools - Polygon

Draws polygons

RMB to close

Normal contour mode

Brush trace mode
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Tools - Text

Adds text to a glyph

Edit tool � moves text

Font � choose from
any
installed TT font
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Tools - Color

Black

White

Empty � the brush takes
the foreground color

Auto � the brush takes
the color where the
stroke begins
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Exercise 2

Create a new glyph design in a blank cell using the
VectorPaint tools.

Add text to make a logo glyph.
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Sketch Mode

141 
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Sketch Toolbar

Show outline � creates a template layer copy of the
contour. This copy remains unchanged while the
contour is edited.

Show marks

New sketch

Import sketch � copies the contour to the sketch layer

Replace outline � replaces the existing contour with
the sketch

Add to outline � adds the sketch to the existing
contour
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Sketch tools

All the usual toolbox tools work in sketch mode.

The main difference between sketch mode and
normal outline mode is that the sketch is not
WYSIWYG. I.e the character contour does not change
as you edit it in the sketch layer.

Only when you click Replace Outline or Add to Outline
does the sketch get transferred to the real character
contour layer.
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Exercise 3

Open the B glyph. Go into sketch mode and put the glyph
outline into the sketch layer.

Make a copy on the template layer and then scale the
glyph 90%.

Use the edit tool to enlarge the upper bowl.

Put the new contour back into the glyph window,
replacing the old contour.
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Expand Strokes & Parallel
Paths

145 
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Expand Strokes

Draw and or select a line
segment

Choose stroke width,

Caps,

Joins,

And shape
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Parallel Paths

Draw and/or select a
segment

Choose relative position,

Replace or add,

Close contour?,

And offset
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Transformations

Glyph edit transform tool

Range transformation

Transformation programs
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Glyph transform tools

Scale

Skew

Rotate
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Glyph transform - scale

Select segment or contour

Click scale tool

Position cursor

Click and drag
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Glyph transform - skew

Select segment or
contour

Click skew tool

Position cursor

Click and drag
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Glyph edit transform - rotate

Select segment or contour

Click rotate tool

Position cursor

Click and drag
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Glyph transform � free transform

Select segment or contour

Click free transform tool

Click on handles for scale,
skew or rotate

Drag to position
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Transform Panel

Window->Transform panel

Enables digital precision transforms

155 

9

Exercise 1

Open the S character

Scale it down to about 90%

Slant it left about 15
degrees

Rotate it about 30 degrees
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Range Transformation
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Range Transformation

Tools -> Transform
(Action)
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Range Transformation

Select a range or character

Select an action

Click OK to apply
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Exercise 2

Open a sample font

Widen all the caps by 10%.

Make all the lower case characters 20% bolder.
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Transformation Programs
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Transformation Programs

Select a range or character (or
leave blank to do the whole
font)

Tools -> Action set
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Transformation Programs

Setup
Transformation
program

Choose range
Retrieve or create
an action set
Edit the actions
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Transformation Programs

The Preview Panel

Run the Action Set
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Exercise 3

Create a transformation program that makes the font
10% bolder, slanted by 6 degrees left, and applies a
shadow.
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



 

 
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 

   

Making a PostScript language implementation of a typeface design
involves two essential considerations:

The character paths must accurately express the true analog
shapes of the original design.
Certain conventions must be observed to help the interpreter
accurately scale for all sizes.

Failure to observe either of these conventions can result in uneven
stems, unwanted pixels, poor curve shapes, and poor transitions
from straight to curved sections.
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 

  

An endpoint (first or last point of a
lineto or curveto) should be placed at
most horizontal or vertical extremes.
This implies that most curves should
not include more than 90 degrees of
arc. The placement of extreme points
aids the rendering algorithms in
properly reproducing the major
features of characters. Of course,
points may be placed anywhere else
on the character outline, as long as
the important extremes are defined as
well. It is not necessary to place an
endpoint at extremes of very small
curves such as the tips of curved
serifs.
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 

 

Whenever one path element should
make a smooth transition to the next
element (for example, straight line to
curve, curve to straight line, or curve
to curve) the endpoint joining the two
elements and the Bézier control
points (the off-curve points)
associated with that endpoint (for
curves) or the other endpoint (for
lines) should all be collinear. This is
especially important at horizontal and
vertical extremes, where slight
deviations tend to be magnified by
interaction with the pixel grid.
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 



Be as concise as possible, without breaking the
other rules. This achieves minimum memory
usage and maximum speed in the rendering
system, and simplifies the task of adding hints.

Use the fewest Bézier curve segments
that accurately represent a shape.
Do not use consecutive collinear straight
line segments.
Do not draw straight lines by using
collinear curveto definitions
Whenever possible, use the closepath
command to draw one of the straight
line segments, rather than closing a
character with a closepath that results in
a zero-length line segment.
In general, find the smallest sequence of
commands that accurately describe the
character shape.
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 

 set of algorithms that analyses a glyph�s outline to find
errors that may decrease glyph rasterization quality.

To activate, press the ying-yang button on the Show Layers
toolbar. To see a description of a possible error, click on the red
arrow mark.
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 
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 

173 

9



Tools / Outline / : FontLab tries to automatically adjust
the outline to remove unnecessary elements and correct others.

Remove unnecessary curve and line segments.
Align imprecisely directed vertical and horizontal lines.
Correct the connection types of lines and curves.

: Preferences / Font Audit / Optimized
Outline Simplification level: The bigger value, the more curves
FontLab will try to remove.
Auto-alignment level: The bigger value, the stronger FontLab
will align curves.
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Metrics
in

FontLab Studio 5

Ted Harrison
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The Metrics Window

Window ->New Metrics Window
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Interface

Mode
Text
Preview
Metrics
Kerning

Size

Options

Tools

String
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Interface

Header bar

Size

String
select

Load text

Open/close
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Metrics button bar
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Metrics button bar

Open Metrics � opens a
metrics file from disk

Save metrics � saves a metrics
file to disk

Quick Save � saves a metrics
file to RAM (not disk)

Quick Open � opens a metrics
file from RAM
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Metrics button bar
Auto

Metrics

kerning
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Metrics button bar

Reset kerning

Assistance

Add pairs
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Metrics button bar

Right-to-
left

Flip glyphs
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Metrics button bar

Measurement line

Class kerning
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Metrics button bar

Expand
panel

Open
Kerning
Table

Ruler
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Metrics Modes
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Metrics Modes

Text
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Metrics Modes

Preview
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Metrics Modes

Metrics
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Metrics Modes

Kerning
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Working with Strings
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String Field

String selections

Entering strings
Type one in

By name: /A.small/
By decimal code: /44
By Unicode: \0445
For slashes use double
slashes: \\ //

Select from dropdown list
Cycle through list using spin
buttons
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String Field

Loading text
strings

List comes from
preview.txt in
data subdirectory
of fontlab
directory. ASCII
editable.

Make your own
list(s) and use the
OPEN button to
load them.

Second preview
allows comparison
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Editing Metrics

194 

21

Editing Metrics

Select Metrics Mode

Select or enter string

Select character

Adjust sidebearings
Manually

Drag sidebearing
line
Drag glyph

Digitally
Use spin buttons
Enter numbers in
spinbox or table
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Editing Metrics

Or just click the Auto button:

And select appropriate
parameters:
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Editing Kerning
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Editing Kerning

Select Kerning Mode

Select or enter string

Select character

Adjust kerning
Manually

Drag kerning line
Drag glyph

Digitally
Enter numbers in table
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Editing Kerning

Or just click the Auto button:

And select appropriate parameters:
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The Measurement Line

On/Off button in Metrics toolbar

Useful for kerning italics
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Advanced
Metrics an

Class Kerning

 

 
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  

FontLab 4.6
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  

FontLab Studio 5
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  

New: �Text Mode� that allows live multiline text editing
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  

New: Permanent Metrics/Kerning table (Metrics mode)
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  

New: Permanent Metrics/Kerning table (Kerning mode)
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   

Glyph class
A named group of glyphs associated together
Used for advanced metrics editing, class kerning and for
OpenType Layout features
�FontLab classes� and �OpenType classes�

FontLab classes
Editable in the Collection/Classes panel & in Kerning Assistance
Usable in Metrics Window, Classes panel, other UI elements

OpenType classes
Editable in the OpenType panel or an external .FEA OpenType
feature definition file
Only usable within the OpenType panel, optional
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   

FontLab classes vs. OpenType classes
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   

Converting OpenType classes FontLab classes
automatic, upon opening an OpenType font (4.6)
manual, �Import FontLab classes� in OpenType panel (5.0)

Converting FontLab classes OpenType classes
automatic, upon compiling features or generating an
OpenType font, if option enabled in Preferences (4.6):

manual, �Import features from binary tables� (5.0)

Most users only need to deal with FontLab classes!

A font creator may use OpenType classes when he/she wants
to create a complete .FEA feature definition file � all in one
file. Otherwise, always use FontLab classes.
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 

FontLab kerning classes
special FontLab classes used for class kerning
name must start with underscore (e.g. �_A�)
one glyph in the class must be a �key glyph�:
its glyph name in class definition is followed by quotesingle (')
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 

1. Create  

2. Define the   of each kerning class

3. Define   for individual glyphs
(for classes, only key glyphs need to be kerned)

4. Use   to copy kerning values
from pairs with key glyphs to pairs with dependant glyphs

  are made by kerning dependant glyphs explicitly
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 

1. Create kerning classes by dragging glyph groups
into classes panel or writing class definition file.
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2. Define the kerning scope of each class
using Kerning Assistance (Save changes):
1st glyph class, 2nd glyph class, both-side class
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 

3. Define kerning pairs for individual glyphs.
For glyphs in classes, you only need to define
kerning pairs with key glyphs.
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  

New: Live class kerning
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 

4. Use Kerning Assistance to apply changes:
Apply and Save
build OpenType �kern� feature with class kerning,
for OpenType PS and OpenType TT fonts
Expand Kerning
physically copy kerning values to dependant glyphs,
for Type 1 and TrueType fonts to be used in
non-OpenType applications
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  

Improved: Expanding class kerning into plain kerning
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  

Improved: Expanding class kerning into plain kerning
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  

New: Compressing kerning into class kerning
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  

New: Metrics window options
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Mysteries
of the

Font Heade

 

Fontlab Ltd.
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 

Font Settings
Font-centric. Affect a given font regardless of which user and
machine it is edited on. They �travel� with the .VFB font file.
Control font naming and identification, metrics and
dimensions, glyph naming and encoding, screen display
settings, other font format-dependant settings.

Application Settings
User-centric. Affect all fonts edited by the current user on the
current machine. Do not �travel� with the .VFB font file.
Control FontLab�s behavior, opening and saving, user interface
elements, keyboard shortcuts etc.
Also control certain aspects of font naming, encoding, screen
display settings etc. of fonts that are being generated.
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  

Font Settings

Font Info (�Info�): File | Font Info...,
May override format-specific application settings

Application Settings

Preferences (�Pref�):
FontLab | Preferences (Mac) or Tools | Options (Win)

Customize: Tools | Customize...

File Dialogs: File | Open... | Options... or File | Generate
Font... | Options..., Temporarily override Preferences
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   

User interface
Font Window, Glyph Window, colors, fonts, smoothing,
keyboard shortcuts, toolbar and menu items*, UI icons*...

Behavior of certain functions
Optimize, FontAudit, Trace, T1/TT Autohinting, copy-paste,
tracking, snapping, selecting, node moving...

Importing (opening) and exporting (generating) fonts
Decompose composites on import, autohint unhinted glyphs,
re-encode glyphs...
Read/export: original hinting, complete �name� table,
OpenType Layout tables, embedded bitmaps...

* only available in FontLab for Windows
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   

Unicode compatibility:
yes: Win TrueType / OpenType TT, OpenType PS,

FontLab VFB, Mac TrueType,
no: Mac / PC Type 1, Mac / PC MultipleMaster

Terminology:
The terms OpenType TT and Win TrueType are interchangeable
OpenType PS (CFF) is often misnamed as just �OpenType�

Settings:
OpenType settings apply both to
Win TrueType / OpenType TT and to OpenType PS fonts
TrueType settings apply to
Win TrueType / OpenType TT and to Mac TrueType fonts
Type 1 settings apply to Mac Type 1 and Win Type 1 fonts
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  

Preferences | Type 1
Type 1 import: leave default settings
Type 1 export
Disable Use WinAscent and WinDescent...
Encoding options: Select encoding automatically
(more discussion when we will speak of font formats)

Preferences | TrueType
TrueType import
For round-tripping, enable Store custom TrueType tables
TrueType export
Disable Autohint unhinted glyphs

Note: �Type 1 settings apply to Mac & Win. �TrueType� settings
apply to Mac TrueType, Win TrueType and OpenType TT (.ttf).
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  

Preferences | OpenType
OpenType import
Disable Interpret �mort� table.
Set Read all OpenType name records...
OpenType export
Set Append OpenType name records for Roman fonts or in
development mode. For shipping, set Export only OpenType
name records and verify all naming in detail.
Enable Use OpenType names as menu names on Macintosh.
Enable Add all glyph classes to OpenType feature definition...

Note: Settings apply to Win TrueType, OpenType TT (.ttf) and
OpenType PS (.otf) fonts. Naming settings also apply to Mac
TrueType.
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   

Font names and identification
Font names, design credits, vendor information,
copyrights and licenses, version numbers, creation date

Metrics and dimensions
UPM, ascenders / descenders, superscript / subscript

Glyph naming and encoding
Glyph names, Unicode values, codepages

Screen display settings
PostScript and TrueType hinting, auto-aliasing

Other settings
Settings specific to given font format
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   

Info | Names and Copyright
Names of font family and style
Font family relations
Typographic parameters (width, weight, inclination)
Design credits, copyrights, trademark information
Licensing information and embedding rights

Info | Version and Identification
Version information
Typeface classification parameters
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     

�Brief� families on Windows
(no more than 4 styles)

�Long� families on MacOS
and in Adobe applications
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     

�Brief� families on Windows
(no more than four styles)

�Long� families on MacOS
and in Adobe applications

Solution: give each family two
sorts of family naming: �brief
family naming� and �long family
naming�.
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  

Brief family naming
FontLab 4.6

Long family naming (�OT�)
Alt. view in FL Studio 5

To switch the views:

Improved Fonts panel in FontLab Studio 5 displays both types of naming
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     

Brief family naming

Long family naming
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   

Start by giving an identical Family
Name (here: LabFont Pro) to all
styles in your family.

Select a Weight and a Width that
best matches the true design of
each style. For light fonts, avoid
the �Thin�, �UltraLight� and
�ExtraLight� settings and choose
�Light� instead.

If your style is italic or oblique,
check the �Font is italic� mark,
but leave �Font is bold�
unchecked at this stage.

234 

23

   

Click on the �Build Style Name�
button to automatically build a
style name.

Abbreviate excessively long style
names (e.g. replace �Condensed�
with �Cond�). The style name
must be unique within the
family, so if FontLab builds the
same style name for two different
fonts, revise one of them.

Click on the �Build Names�
button to automatically build the
remaining names.

Click on the �Verify names�
button (new in FL Studio 5!)
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   

Switch between styles and
repeat the previous steps
analogically for all styles in your
family.

Go to the �OpenType-specific
font names� page and click on
�Build OpenType Names�.
Repeat for all styles in the family.
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   

Go back to the �Basic set of font
names� page and apply the
brief family naming:

Enter the brief family name into
the Family Name field and into
the Menu Name field.

Enable �Font is bold� whenever
a font is supposed to be �bold
style� within the brief family.

Revise the �Style Name� field so
it only contains one of the
following: �Regular�, �Italic�,
�Bold� or �Bold Italic�.

Leave other settings unchanged.
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   
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   
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   
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   
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   
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  

243 
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  

244 
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   
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   
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  

Format-specific hinting settings:
Pref | Type 1
Pref | TrueType
Info | Hinting Settings
Info | TrueType-specific settings | Font smoothing
Tool: TrueType Hinting | Stems Options
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  

Finalizing a PostScript design (Type 1 or OpenType PS/CFF)

Tools / Transform Range / range: All characters in the font
Add actions:

Contour / Decompose
Contour / Reverse all / Set counterclockwise (Type 1) direction
Hints and Guidelines / Remove hints/guides
Hints and Guidelines / Autohint
Hints and Guidelines / Autoreplace

Run the program

Font Info
Hinting Settings / Auto zones
Standard stems (T1 hinting) / Auto stems
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  

Finalizing a TrueType design (OpenType TT)

Complete steps on previous page

Font Info
Metrics and Dimensions: Change UPM if required or leave
1000, enable �Scale all glyphs according to UPM change�
TrueType-specific settings / Font smoothing / �Auto� (green)

Tools / Transform Range / range: All characters in the font
Add actions:

Contour / Convert to TrueType
Contour / Reverse all / Set clockwise (TrueType) direction
Hints and Guidelines / Convert to instructions

Run the program
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
 


 
 

250 



   

        

251 



     

 
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

     

 
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

     

 
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

      

255 


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

      

257 


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

      

259 


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

      
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
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

      
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
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

      
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

266 



      
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
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Python
Scripting

in FontLab

 

 
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  

Python is an open source object-oriented
programming language

Python is cross-platform, one code can be executed on
Mac, Windows, Unix etc.

It is easy to learn, very flexible and extremely powerful

Why write code?
simplify batch processing
cut down on repetitive tasks

FontLab has extensive Python implementation
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     

First version of Python was written by Guido van Rossum. Guido van
Rossum is the older brother of Just van Rossum, who is type designer
(Letterror) and ATypI member.

Many years ago, Just van Rossum, Erik van Blokland and
Petr van Blokland wrote RoboFog � a scriptable version
of Fontographer 3.5. It was written in Python.

A few years ago, Just van Rossum wrote TTX, a package that allows you to
convert TrueType and OpenType fonts to XML and back. In Python, of
course.

This year, Just van Rossum, Erik van Blokland and Tal Leming wrote
RoboFab � an extension package that uses FontLab. Again, RoboFab was
written in Python.

Large parts of the Adobe SDK for OpenType (ASDKO,
f.k.a. Adobe OTFDK) are written in Python.
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   

Python 2.3 .x must be installed on your system

For Mac:


Download and install MacPython-OS9 even if you�re on OS X!

After installation, click on �Configure Python�

For Windows:

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   

Macro Edit Panel

Output Panel

Fonts Panel

Context Menus
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  

Python programs are text files,
usually with extension .py

Python is case-sensitive

Literals:
String:   or  

Integer value: 
Floating value: 
List:    

Comment:  

Statement: 
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 

 
  

 
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 

  

 

   

 

    

 

 

 

 
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  

Condition:  ...  statement

Iteration:  statement

   

 

 

   

  

 

 

277 

12

   

FontLab�s objects (fonts, glyphs, nodes) represented
as Python objects

FontLab objects overview
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 

Go through the macros that come with FontLab
and read over them to see how they work.

The Python website has some great tutorials for learning basic
Python:
http://www.python.org

The documentation of the FontLab/Python API is available at:
http://dev.fontlab.net/flpydoc/

There is a mailing list dedicated to Python in FontLab:
http://mail.letterror.com/mailman/listinfo/fontlab-scripting

Almost any introductory book on Python will be helpful

Write macros in an external editor (UltraEdit, BBEdit)

279 

Fontlab Ltd.
http://www.fontlab.com

Blending &
Multiple Masters
in
FontLab Studio 5

Ted Harrison
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Blending

Takes two fonts and creates an intermediate version.
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Blending

Open two fonts

Tools -> Blend Fonts
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Blending

Specify fonts

Blend vs. Build MM

Destination

Glyphs

Blend amount
Uniform?

Interpolate
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Blending

Building a single-axis Multiple Master font
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Multiple Master Fonts
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Multiple Masters Theory

Masters � the designer creates Master fonts to define the
extremes of the design. A single-axis font requires two masters. A
two-axis font requires four Masters. A three-axis font needs 8
Masters and a four axis font (the limit of current technology) needs
16 Masters.

Axes � FontLab interpolates between the Masters to produce all
the intermediate designs (instances). It can also extrapolate beyond
the Masters to produce extraneous designs.
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Multiple Masters Theory

Standard Axes
Weight
Width
Optical size
Style (could be Serif or some other style attribute)
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Multiple Masters Technique

1. Select/create Master

2. Define Axes

3. Create subsequent
Masters
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Multiple Masters Technique

Open the selected Master font

Define an axis
Name
Short name
Axis type
Hints to links
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Multiple Masters Technique

Create a second Master
Select an active Master

Edit
Transform
Blend
Assign
Mask to Master
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Multiple Masters Technique

Assign a second Master

Tools->MultipleMaster->Assign Master
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Multiple Masters Technique

Mask to Master
Assign mask

Tools->Mask&Template->Assign Font mask
Mask to Master

Tools->MM->Mask to Master
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Multiple Masters Technique

The Axis Panel
Window->Axis Panel

The Preview Panel
Window->Preview Panel
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Multiple Masters Technique

MM Metrics

Open Metrics window

Select Master to work on

Edit metrics as in regular font

Save metrics in MMM or AFM files
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Multiple Masters Technique

Working with Axes

Axis settings
Tools->MM->Modify Axis Names

Removing an axis
Tools->MM->Remove Axis
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Multiple Masters Technique

Editing the Axis Graph
Tools->MM->Edit axis
Graph
Choose axis
Position ends of dynamic
range
RMB+LMB(<cmd><opt>)
on the line to add a point
Drag point to new position
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Multiple Masters Technique

Anisotropic Interpolation

Button in Axis panel
Choose axis
Position ends of dynamic
range
RMB+LMB(<cmd><opt>)
on the line to add a point
Drag point to new position
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Multiple Masters Technique

Hinting MM fonts

You could hint each master separately.

But it�s easier to use links instead. Links are not dependent on the
number of masters. On export links will automatically be converted
to hints for each master.
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Multiple Masters Technique

Generating a MM font

File->Generate font

Select MM format
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Multiple Masters Technique

Generating Instances

Tools->MM->Generate
Instance

Select from known instances, or

Choose a design position for a
new instance.

OK-> creates new font and opens
it in a window in FontLab
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